Results 1 to 4 of 4
  1. #1
    BloodSkin's Avatar
    Join Date
    Jun 2010
    Gender
    male
    Location
    Columbus, OH
    Posts
    354
    Reputation
    11
    Thanks
    63

    win7 x64 vs ollydbg

    mk, so i have tried various versions of ollydbg, and the only one that works as it should (non memory errors) is ollydbg 2.0. the version magic uploaded is able to launch the file that is to be debugged, but projects an error when you attempt to actually read anything from memory, ie search for strings. the error is related to ollydbg not being able to read the memory. could it be trying to read from the wrong address? the reason i dont want to use 2.0 is because it is not capable of launching dll's and i dont know how to manually launch them using loaddll.exe. any suggestions on where to go next? new debugger, try to fix 1.3, or try to load a dll into 2.0?

  2. #2
    J's Avatar
    Join Date
    Jun 2010
    Gender
    male
    Location
    East Coast
    Posts
    2,159
    Reputation
    379
    Thanks
    5,760
    My Mood
    In Love
    You need a 64bit compatibility plugin.
    Keep me motivated for my hack development!

  3. #3
    BloodSkin's Avatar
    Join Date
    Jun 2010
    Gender
    male
    Location
    Columbus, OH
    Posts
    354
    Reputation
    11
    Thanks
    63
    Quote Originally Posted by Blood View Post
    You need a 64bit compatibility plugin.
    i thought it was included in that upload by magic. damn i feel retarded. i even read about that via google too....

    EDIT: it already comes with advancedolly, and stealth64 didnt fix anything. soon i will post screenies of the exact errors im getting, i just wanna spend a little more time on it before i admit that i cant fix it on my own.
    Last edited by BloodSkin; 08-22-2010 at 08:46 AM.

  4. #4
    BloodSkin's Avatar
    Join Date
    Jun 2010
    Gender
    male
    Location
    Columbus, OH
    Posts
    354
    Reputation
    11
    Thanks
    63

    OK SO IM STUMPED

    UPDATE







    i was going to replace advancedolly.dll but the file creation/mod/blahblahblah dates were identical so i concluded they were the same build and decided not to. i also added stealth64.dll which still did not resolve either issue. whats funny is i dont get this error on ollydbg 2.0 and was able to verify that i had done it correctly by searching for some strings that are in the sticked ptc topic. but engine.exe just isnt enough for me. there HAS to be something im overlooking. ive confirmed the file paths in the config files and all.

    im enjoying this challenge, im just stuck is all.

    sorry for double post

Similar Threads

  1. Injector on Win7 x64
    By takumo31 in forum CrossFire Help
    Replies: 5
    Last Post: 06-20-2011, 11:53 PM
  2. [Discussion] win7 x64
    By trebligul in forum CrossFire Spammers, Injectors and Multi Tools
    Replies: 21
    Last Post: 06-03-2011, 08:41 PM
  3. Can i Download Win7 x64?
    By tabuzo013 in forum General
    Replies: 4
    Last Post: 10-15-2010, 01:06 PM
  4. win7 x64 vs kernel detective
    By BloodSkin in forum Combat Arms Hack Coding / Programming / Source Code
    Replies: 13
    Last Post: 08-22-2010, 07:00 AM
  5. [Help] Wallhack Doesn't Work After Update Win7 x64
    By hero70077 in forum CrossFire Hacks & Cheats
    Replies: 25
    Last Post: 04-22-2010, 11:21 AM