Results 1 to 8 of 8
  1. #1
    Elguet's Avatar
    Join Date
    Oct 2009
    Gender
    male
    Posts
    10
    Reputation
    10
    Thanks
    1

    Having a problem.

    Hello everyone.

    As I always do before I work with a new hack for a new game, I always test the game by injecting an empty dll but seems like CA EU is detecting empty dll's, can anyone give me a solution to this problem?

    I have tryed everything but nothing seems to be working and I have never worked with a game that detects empty dll's.

    I am just bypassing d3d hooks, everything should be undetected by itself.
    Last edited by Elguet; 02-17-2013 at 02:33 PM.

  2. #2
    TrixtSam's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Posts
    89
    Reputation
    10
    Thanks
    127
    It's not detecting an empty DLL. It's throwing an error, because theirs nothing in the DLL that can make the game continue to run. Theirs no hooks/DLLMain etc..

  3. #3
    Ch40zz-C0d3r's Avatar
    Join Date
    Apr 2011
    Gender
    male
    Posts
    839
    Reputation
    44
    Thanks
    400
    My Mood
    Twisted
    They have got some functions to detect dlls, it could be a fail and they made a pattern of dllmain, or hs is looping through the modules and doesnt like the name or something. Try to unlink the dll from peb and use the hide functions spreaded over here.

    Progress with my game - "Disbanded"
    • Fixed FPS lag on spawning entities due to the ent_preload buffer!
    • Edit the AI code to get some better pathfinding
    • Fixed the view bug within the sniper scope view. The mirror entity is invisible now!
    • Added a new silencer for ALL weapons. Also fixed the rotation bugs
    • Added a ton of new weapons and the choice to choose a silencer for every weapon
    • Created a simple AntiCheat, noobs will cry like hell xD
    • The name will be Disbanded, the alpha starts on the 18th august 2014



    Some new physics fun (Serversided, works on every client)



    My new AI
    http://www.youtube.com/watch?v=EMSB1GbBVl8

    And for sure my 8 months old gameplay with 2 friends
    http://www.youtube.com/watch?v=Na2kUdu4d_k

  4. #4
    Saltine's Avatar
    Join Date
    Jun 2011
    Gender
    male
    Posts
    494
    Reputation
    104
    Thanks
    625
    Quote Originally Posted by Elguet View Post
    Hello everyone.

    As I always do before I work with a new hack for a new game, I always test the game by injecting an empty dll but seems like CA EU is detecting empty dll's, can anyone give me a solution to this problem?

    I have tryed everything but nothing seems to be working and I have never worked with a game that detects empty dll's.

    I am just bypassing d3d hooks, everything should be undetected by itself.
    How empty is empty? Are we talking a 0 byte DLL file with nothing in it, or just a dllmain which does nothing?

    Oh no! Vortex is gay!

  5. #5
    Acea's Avatar
    Join Date
    Oct 2012
    Gender
    female
    Location
    Home of the elks
    Posts
    346
    Reputation
    80
    Thanks
    2,204
    My Mood
    Stressed
    Just do

    Code:
    BOOL __stdcall DllMain(HMODULE hDll, DWORD dwReason, LPVOID lpReserved)
    {
          switch(dwReason)
          {
                case DLL_PROCESS_ATTACH:
                      Messagebox(0,0,0,0);
                break;
          }
    
          return true;
    }
    compile that and inject and it should work fine.

  6. #6
    Elguet's Avatar
    Join Date
    Oct 2009
    Gender
    male
    Posts
    10
    Reputation
    10
    Thanks
    1
    I tryed all of those things, still doesn't works.. Any other method?

  7. #7
    ctpsolo's Avatar
    Join Date
    Jan 2010
    Gender
    male
    Posts
    252
    Reputation
    10
    Thanks
    34
    My Mood
    Amused
    I'm assuming this is something you have done but if not try injecting your dll to another process and just display a messagebox or something. Just to make absolute sure it's not an issue on your behalf.

    I had the same problem years ago when I was using Dev-cpp/GCC. I spent days trying to inject a dll I made but nothng would happen. I assumed it was an issue with process attach not getting called but nothing worked, not even the template for dll's provided by Dev. Finally I tried doing it in VS instead and it worked fine right away when injecting. Never figured out what was wrong.

    And add more info, what happens when you inject? Does CA terminate? Nothing happens? You sure it's not an issue with your injector? I heard some public injectors crash/are detected but I dunno since I'm using a private loader for CA.
    Last edited by ctpsolo; 03-03-2013 at 09:55 AM.
    They're out ta get me!

    Persistence is an art in itself. Let them slam each door in your face, even reject the whole definition of who you are. There will be a day when they come knocking on your door instead.

  8. #8
    Elguet's Avatar
    Join Date
    Oct 2009
    Gender
    male
    Posts
    10
    Reputation
    10
    Thanks
    1
    Exactly.. I crash when I even try to inject an empty dll... I talked to other coders and they said that CA EU
    does crc checks and your injector can become detected but im not sure about..

Similar Threads

  1. Okay so I have a problem
    By appletart in forum Combat Arms Hacks & Cheats
    Replies: 5
    Last Post: 08-16-2008, 02:55 PM
  2. Have a problem with my Korean Warrock Acc
    By Kevin.B in forum WarRock Korea Hacks
    Replies: 2
    Last Post: 08-09-2008, 03:26 PM
  3. hi i have a problem
    By priit1 in forum WarRock - International Hacks
    Replies: 2
    Last Post: 12-20-2007, 12:36 PM
  4. i have a problem
    By priit1 in forum WarRock - International Hacks
    Replies: 5
    Last Post: 09-27-2007, 01:16 PM
  5. i have a problem
    By mpghhackersrock123 in forum WarRock - International Hacks
    Replies: 15
    Last Post: 09-26-2007, 08:28 AM