Results 1 to 6 of 6
  1. #1
    buddhayang's Avatar
    Join Date
    Jul 2012
    Gender
    male
    Location
    USA
    Posts
    141
    Reputation
    10
    Thanks
    90

    CPU won't turn on

    My computer won't turn on so I'm using my iPod right now. This is what happened when it won't turned on. I updated my vista 64 bit pc to the windows service pack 2 and after the update my computer feels laggy but when I checked my ping it's normal so after using the CPU for a while I ahutted it down and it took so long to shut down so I just pulled the power cord from the wall (usually it turns back on if press power button) then I pressed the power back on but it won't turn on and I repulled the cord again and tried turning it on but nothing happens no fans no light or anything. I even tried switching power outlets. I don't know if my ram is fried or something help??

    Windows vista 64 bit
    Somebody help me???

  2. #2
    Hero's Avatar
    Join Date
    Feb 2011
    Gender
    male
    Location
    MPGH.NET
    Posts
    33,754
    Reputation
    3155
    Thanks
    7,896
    Since this is more of a 'computer' issue, moved.



    Donator since 09•16•2011
    Minion since 10•10•2011
    Minion+ since 01•06•2012
    Moderator since 08•08•2012
    Global Moderator since 10•06•2012
    Editor from 06•14•2011 • 2014


    [ • ] [ • ] [ • ] [ • ][ • ]


  3. #3
    tonyiscool101's Avatar
    Join Date
    Jun 2011
    Gender
    male
    Location
    where my dreams take me
    Posts
    478
    Reputation
    10
    Thanks
    21
    My Mood
    Bored
    send it to a computer repair store

  4. #4
    Asbeel's Avatar
    Join Date
    Aug 2012
    Gender
    male
    Posts
    34
    Reputation
    10
    Thanks
    1
    You need to give a good maintenance

  5. #5
    Alen's Avatar
    Join Date
    Oct 2007
    Gender
    male
    Location
    Liquid Generator
    Posts
    27,930
    Reputation
    2539
    Thanks
    4,216
    My Mood
    Fine
    The PSU probs went if nothing happens when you power it up. Or the mobo, though I find that less likely. Either way get it looked at by a professional, it's kinda obvious that you don't really have much experience when it comes to computer hardware.

  6. #6
    buddhayang's Avatar
    Join Date
    Jul 2012
    Gender
    male
    Location
    USA
    Posts
    141
    Reputation
    10
    Thanks
    90
    Quote Originally Posted by Alen View Post
    The PSU probs went if nothing happens when you power it up. Or the mobo, though I find that less likely. Either way get it looked at by a professional, it's kinda obvious that you don't really have much experience when it comes to computer hardware.
    well i got it fixed while i was cleaning the dust but when i cleaned the dust it still didnt worked, but my dad told me to unplug it and tomorrow were going to take it to a friend of his to inspect the computer. as i unplugged it for a lil while like 5 min. and i was just curious and i plugged it back in.. so now it works but i have another question...

    When i updated it to windows vista service package 2-64 bit system. it makes my screen lag, but when i check the ping its pretty normal like always can someone help me? this is the first time its happend after an update

Similar Threads

  1. France turned straight!
    By sf0d in forum Debate Fort
    Replies: 18
    Last Post: 10-20-2008, 02:47 PM
  2. Australia won...
    By Gourav2122 in forum Flaming & Rage
    Replies: 0
    Last Post: 09-28-2007, 07:19 PM
  3. How to overclock CPU processor?
    By thechewu in forum Hardware & Software Support
    Replies: 8
    Last Post: 08-11-2007, 09:04 PM
  4. How do we turn on blood effects?
    By iHack in forum WarRock Korea Hacks
    Replies: 3
    Last Post: 08-09-2007, 09:16 PM
  5. Turning ce into UCE
    By thedrowningfish in forum WarRock - International Hacks
    Replies: 2
    Last Post: 07-24-2007, 12:38 AM