Hey
I had a little problem with my computer and restored it up to the time before the 1.3.362 patch so it went for me from 1.3.362 to 1.2.359.
What can i do to update my client manually ? plz help