Results 1 to 6 of 6
  1. #1
    Symboliq's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Location
    420.69.1337.7010
    Posts
    1,613
    Reputation
    234
    Thanks
    318

    I think I broke my GPU

    Was upgrading everything. Added new CPU fan, case, and HDD. Had a couple things go wrong but fixed it. My Gigabyte AMD Radeon HD 7950 stopped working. Fans are still spinning and connected but when I plug into monitor it doesn't work. My integrated graphics work and all I just need my GPU to work. It doesn't show up on device manager either. I was blowing it out with a small air compressor if that matters. It was to clean the dust out. I cleaned it well though. Please help someone.

    Edit: Edit: I Pushed on it to make sure it was in place and now my computer wont turn on. I am sure all the wires are connected correctly and now it wont even turn on. Not one sign of life.
    Last edited by Rance-Llama; 05-17-2014 at 01:37 PM.

  2. #2
    Aborted's Avatar
    Join Date
    Nov 2010
    Gender
    male
    Location
    Shitpost Defense
    Posts
    17,471
    Reputation
    3076
    Thanks
    6,394
    My Mood
    Twisted
    ​Make sure you're connecting your cable to your GPU and not your Motherboard, you'd be surprised at how many people make that mistake. Also check your BIOS and make sure your primary Graphics Device is set to PCIE and not Integrated.
    When the earth is changed into a humid dungeon,
    In which Hope like a bat
    Goes beating the walls with her timid wings
    And knocking her head against the rotten ceiling;
    When the rain stretching out its endless train
    Imitates the bars of a vast prison
    And a silent horde of loathsome spiders
    Comes to spin their webs in the depths of our brains,
    All at once the bells leap with rage
    And hurl a frightful roar at heaven,
    Even as wandering spirits with no country
    Burst into a stubborn, whimpering cry.
    — And without drums or music, long hearses
    Pass by slowly in my soul; Hope, vanquished,
    Weeps, and atrocious, despotic Anguish
    On my bowed skull plants her black flag.

  3. #3
    Stonerdays's Avatar
    Join Date
    May 2014
    Gender
    male
    Location
    WeeeeeeeD
    Posts
    487
    Reputation
    33
    Thanks
    24
    Trolololol.

  4. #4
    Symboliq's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Location
    420.69.1337.7010
    Posts
    1,613
    Reputation
    234
    Thanks
    318
    Quote Originally Posted by Aborted View Post
    ​Make sure you're connecting your cable to your GPU and not your Motherboard, you'd be surprised at how many people make that mistake. Also check your BIOS and make sure your primary Graphics Device is set to PCIE and not Integrated.
    Edit: I Pushed on it to make sure it was in place and now my computer wont turn on. I am sure all the wires are connected correctly and now it wont even turn on. Not one sign of life.

  5. #5
    Grå's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Location
    Sweden
    Posts
    13,352
    Reputation
    2486
    Thanks
    9,507
    Quote Originally Posted by Doge+ View Post
    Edit: I Pushed on it to make sure it was in place and now my computer wont turn on. I am sure all the wires are connected correctly and now it wont even turn on. Not one sign of life.
    Sort of sounds like you burnt your PC with static electricity.
    Can you see a light near your motherboard battery?

  6. #6
    Symboliq's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Location
    420.69.1337.7010
    Posts
    1,613
    Reputation
    234
    Thanks
    318
    Quote Originally Posted by Vinternatt View Post
    Sort of sounds like you burnt your PC with static electricity.
    Can you see a light near your motherboard battery?
    yes I do actually. And where I live it is VERY Humid and you will almost NEVER get shocked by static electricity even if you rub your socks on carpet for hours.

Similar Threads

  1. [Help Request] I broke my monitor(I think)
    By Snake in forum Hardware & Software Support
    Replies: 2
    Last Post: 05-05-2012, 10:06 AM
  2. i think i'll jump on the band wagon
    By A7X Oblivian in forum Art & Graphic Design
    Replies: 6
    Last Post: 07-18-2006, 10:38 PM
  3. I Broke My Ass
    By JTLOBAMHSK in forum Entertainment
    Replies: 19
    Last Post: 06-09-2006, 08:13 PM
  4. Irc Is Broked
    By Kyojiro in forum Entertainment
    Replies: 27
    Last Post: 05-26-2006, 12:23 AM
  5. i think its time for a new sig
    By darkone1149 in forum Help & Requests
    Replies: 9
    Last Post: 02-06-2006, 04:52 PM