Results 1 to 9 of 9
  1. #1
    Symboliq's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Location
    420.69.1337.7010
    Posts
    1,578
    Reputation
    234
    Thanks
    318

    Anyone Been Having Steam Problems?

    "Unable to connect to server. Server may be offline or you may not be connected to the internet." is the message that I've been getting. It's been happening after the past week. Almost 90% of the time when I am trying to access something on Steam it happens. I even reset my IP and router and everything. It keeps happening and it is starting to piss me off. I can't do anything. I am still logged in and everything. It happens on my web browser as well. Anyone else? or fix?

  2. #2
    ThePixelJunk's Avatar
    Join Date
    Mar 2013
    Gender
    male
    Location
    New zealand
    Posts
    1,458
    Reputation
    217
    Thanks
    263
    Check the date on your pc. Sometimes its set to a date the site does not have a valid security certificate for.
    Can't pass through the red plastic window.

  3. #3
    Symboliq's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Location
    420.69.1337.7010
    Posts
    1,578
    Reputation
    234
    Thanks
    318
    Quote Originally Posted by ThePixelJunk View Post
    Check the date on your pc. Sometimes its set to a date the site does not have a valid security certificate for.
    Sunday March 23, 2014 7:48 PM

  4. #4
    Justin's Avatar
    Join Date
    Jul 2009
    Gender
    male
    Location
    Melbourne, Australia
    Posts
    7,022
    Reputation
    1207
    Thanks
    2,825
    My Mood
    Inspired
    I'm all sweet on my end. You seem to be having a lot of issues lately Rolluhp, hope you get out of this rough patch bud.

    Minion Statistics

    Ex-Console Minion: 13/01/2011 ~ 19/04/2011
    Console Re-Minion: 14/06/2012 ~ 27/02/2013
    AVA Minion: 22/06/2012 ~ 12/11/2012
    Battlefield Minion: 04/02/2013 ~ 27/02/2013

    Computer Specifications
    Case: NZXT Phantom 820
    PSU: Corsair HX-850W V2
    Mobo: ASUS Z87-Deluxe
    CPU: Intel Core i7-4770K
    CPU Cooling: Swiftech H220 All-In-One Liquid Cooler (Cooled by 2x Noctua NF-F12 PWM 120mm Fans)
    RAM: Corsair Platinum Dominators CMD16GX3M2A2400C10 (2x8GB DDR3 2400Mhz XMP)
    GFX: ASUS GeForce GTX 770 DirectCU II OC 2GB
    Monitor: LG 29EB93 29" Ultrawide LED IPS Panel (2560x1080)(29:1 Ratio)
    Mouse: Razer Deathadder 2012
    Keyboard: Ducky DK 9008G2 Cherry MX-Brown Mechanical Keyboard


  5. #5
    Symboliq's Avatar
    Join Date
    Nov 2012
    Gender
    male
    Location
    420.69.1337.7010
    Posts
    1,578
    Reputation
    234
    Thanks
    318
    Quote Originally Posted by Justin View Post
    I'm all sweet on my end. You seem to be having a lot of issues lately Rolluhp, hope you get out of this rough patch bud.
    Wow someone actually cares and is nice. . . on MPGH. Thanks buddy. I really appreciate it.

  6. #6
    Astro.'s Avatar
    Join Date
    Jul 2012
    Gender
    male
    Posts
    3,697
    Reputation
    537
    Thanks
    644
    My Mood
    Amused
    I have this problem from time to time, I'll either login on offline mode and then click on Steam (top left) and click exit. Then reopen Steam and relogin, hopefully that works for you
    Godlike.

  7. #7
    Rance-Sama's Avatar
    Join Date
    Aug 2012
    Gender
    male
    Location
    Ice
    Posts
    6,337
    Reputation
    653
    Thanks
    8,065
    Solution 1 - Download more malware
    Solution 2 - fuk gaben
    Solution 3 - drink bleach

    pls thx/rep and suk my dik if i helped

  8. #8
    Ghost's Avatar
    Join Date
    Jun 2009
    Gender
    male
    Location
    Under your bed, watching you sleep.
    Posts
    24,674
    Reputation
    3481
    Thanks
    3,603
    happened a few times to me and some friends last week so, not just you



    My games;

    x

  9. #9
    Daumcow's Avatar
    Join Date
    Sep 2012
    Gender
    male
    Posts
    72
    Reputation
    10
    Thanks
    37
    I've had the same problems.
    1) Check your Anti-Virus. Maybe it blocked Steam.
    2) Check your login information. Maybe you're typing it wrong.
    3) Check Steam's status when you log in. It could be that:
    • Steam is getting booted
    • Steam is down for maintenance
    • Steam servers blew up.


    That's pretty much all I can think off ATM.

    Hope I helped!

Similar Threads

  1. [Discussion] Anyone else having audio problems?
    By luisrosado in forum Minecraft Discussions
    Replies: 6
    Last Post: 05-10-2013, 12:51 AM
  2. [Help Request] anyone else having this problem?
    By thesinerd in forum Alliance of Valiant Arms (AVA) Help
    Replies: 5
    Last Post: 08-22-2012, 12:58 AM
  3. anyone else having this problem with instant draw?
    By akkuro in forum Combat Arms Mod Discussion
    Replies: 6
    Last Post: 12-23-2010, 03:48 PM
  4. Anyone else having CA problems?
    By eliteusername in forum Combat Arms Discussions
    Replies: 9
    Last Post: 08-28-2010, 04:41 AM
  5. Anyone else have patching problems!!??
    By eliteusername in forum Combat Arms Discussions
    Replies: 12
    Last Post: 07-28-2010, 07:57 PM