Results 1 to 11 of 11
  1. #1
    FreeMarketGuy's Avatar
    Join Date
    Apr 2013
    Gender
    male
    Posts
    954
    Reputation
    105
    Thanks
    73

    Fried USB ports ? Need help.

    I made a thread a while back about it , but couldn't reply to it.

    Well , now I'm at the edge of shooting my computer out of the window -_-.

    None of my USB ports are working and I need help asap cause I can't use my headset and gaming mice because of this problem.

    I would appreciate some tips , or if my motherboard is defective I need for someone to confirm it.

    Thanks in advance.





  2. #2
    αяgуяσѕ's Avatar
    Join Date
    Apr 2010
    Gender
    male
    Location
    A Box
    Posts
    1,726
    Reputation
    64
    Thanks
    143
    My Mood
    Lurking
    Quote Originally Posted by FreeMarketGuy View Post
    I made a thread a while back about it , but couldn't reply to it.

    Well , now I'm at the edge of shooting my computer out of the window -_-.

    None of my USB ports are working and I need help asap cause I can't use my headset and gaming mice because of this problem.

    I would appreciate some tips , or if my motherboard is defective I need for someone to confirm it.

    Thanks in advance.




    Try wetting your finger and then try shoving your finger in the port if you get a shock then your ports are working fine.

    Well in seriousness if your device manager is saying it works then it works, if it was fried the ports wouldn't be working or listed.
    Make sure you have the driver drivers for your ports and hardware.
    Quote Originally Posted by Dave84311 View Post
    Valid keys, he gave me one himself.
    [IMG]https://i50.*******.com/2ih2ik6.png[/IMG]
    ____________________________
    Need help? Pm me
    ___________________________
    Please Press The Thanks If I Helped

  3. #3
    FreeMarketGuy's Avatar
    Join Date
    Apr 2013
    Gender
    male
    Posts
    954
    Reputation
    105
    Thanks
    73
    Quote Originally Posted by D3DR3VO View Post
    Try wetting your finger and then try shoving your finger in the port if you get a shock then your ports are working fine.

    Well in seriousness if your device manager is saying it works then it works, if it was fried the ports wouldn't be working or listed.
    Make sure you have the driver drivers for your ports and hardware.
    The motherboard came with an installation CD , I installed it , but nothing changed..

    Edit: Installing again , just in case.
    Edit: My USB ports are a lost cause.
    I'll just use the Pci to USB adapter..fml
    Last edited by FreeMarketGuy; 09-26-2013 at 04:58 AM.

  4. #4
    Aborted's Avatar
    Join Date
    Nov 2010
    Gender
    male
    Location
    Shitpost Defense
    Posts
    17,623
    Reputation
    3137
    Thanks
    6,446
    My Mood
    Twisted
    ​Sounds like you have a bad mobo connection.
    I am the seer in the dark,
    the vagabond of yore,
    valediction.
    I am the sum of all your parts,
    and proprietor of all.
    A miasma,
    the conclusion,
    blackmonger of Inl้,
    valediction.
    Synapses fray,
    my form now vivid,
    as torpor sets and blood grows tepid.
    With every ounce of flesh now offered,
    I hold your corpse within my coffers.
    Knitted cells now split asunder,
    stand alongside me brother.
    Take your place amongst my Owsla,
    we march at dawn now and forever.


  5. #5
    FreeMarketGuy's Avatar
    Join Date
    Apr 2013
    Gender
    male
    Posts
    954
    Reputation
    105
    Thanks
    73
    Quote Originally Posted by Aborted View Post
    ​Sounds like you have a bad mobo connection.
    You mean , the cables that connects to the mob ?

    A professional connected them , at least , from what I think..

  6. #6
    3kc's Avatar
    Join Date
    Mar 2013
    Gender
    male
    Location
    USA
    Posts
    173
    Reputation
    103
    Thanks
    15
    My Mood
    Sneaky
    best advice i can give is go to your motherboard site and download the proper drivers for usb ports on your model.

  7. #7
    WhiteDagger's Avatar
    Join Date
    Apr 2010
    Gender
    male
    Location
    Ohio,
    Posts
    955
    Reputation
    16
    Thanks
    35
    My Mood
    Amused
    Did you try turning it off and on again?

  8. #8
    Black's Avatar
    Join Date
    Jan 2012
    Gender
    male
    Location
    Dave's Heart and/or Arun's Ballsack
    Posts
    3,579
    Reputation
    816
    Thanks
    2,210
    My Mood
    Fine
    Quote Originally Posted by WhiteDagger View Post
    Did you try turning it off and on again?
    lel. How dumb do you thinke he is

  9. #9
    3kc's Avatar
    Join Date
    Mar 2013
    Gender
    male
    Location
    USA
    Posts
    173
    Reputation
    103
    Thanks
    15
    My Mood
    Sneaky
    your signature gif is amazing

  10. #10
    FreeMarketGuy's Avatar
    Join Date
    Apr 2013
    Gender
    male
    Posts
    954
    Reputation
    105
    Thanks
    73
    Quote Originally Posted by shaheet View Post
    lel. How dumb do you thinke he is
    I'm far from dumb boy. I just have no experience in broken parts.
    Anyways my problem is fixed. I bought a PCI to USB adapter.
    @Hero close plz

  11. #11
    Hero's Avatar
    Join Date
    Feb 2011
    Gender
    male
    Location
    MPGH.NET
    Posts
    35,989
    Reputation
    3320
    Thanks
    8,313
    Solved .





    Donator since 09•16•2011
    Minion since 10•10•2011
    Minion+ since 01•06•2012
    Moderator since 08•08•2012
    Global Moderator since 10•06•2012
    Editor from 06•14•2011 • 2014


    [ • ] [ • ] [ • ] [ • ][ • ]


Similar Threads

  1. Need help port forwarding !
    By Cheeky Jim in forum General
    Replies: 18
    Last Post: 06-21-2013, 10:59 AM
  2. [Solved] need help with port foward!!
    By vivamoi in forum Minecraft Help
    Replies: 2
    Last Post: 07-03-2012, 07:47 PM
  3. NEED HELP ON HOW TO FIX WRITE PROTECTED USB DISK
    By killbyme in forum Suggestions, Requests & Help
    Replies: 3
    Last Post: 09-25-2011, 11:16 PM
  4. [Help Request] need help with modding
    By BayBee Alyn in forum Combat Arms Help
    Replies: 0
    Last Post: 04-27-2011, 09:06 PM
  5. Need Help for an error in MM port
    By Murat in forum CrossFire Help
    Replies: 11
    Last Post: 01-24-2011, 06:21 AM