Opens fine but when I connect it crashes, guessing because it's outdated. Is there any way to update this on my own? I've been trying to google an updated version but can't find any.