Can this work in 1.7 or no